Voipography Services - Inbounds calls are delayed and/or timing out. Service degradation. Investigating on the issue – Incident details

Inbounds calls are delayed and/or timing out. Service degradation. Investigating on the issue

Resolved
Partial outage 30 %
Started 3 months agoLasted about 12 hours

Affected

Connectivity

Partial outage from 8:12 PM to 8:03 AM

Inbounds

Partial outage from 8:12 PM to 8:03 AM

Updates
  • Resolved
    Resolved

    The services are now stable, and we continue to monitor the platform

  • Monitoring
    Monitoring

    Implemented a fix for this issue and our metrics currently indicate call success rates have returned to normal levels.
    Customers may have experienced call failures and dead air on inbound in any region, with the majority of impact affecting North America.

    The list of impacted services has been confirmed as follows:
    Inbound Voice Calls

    We will continue to monitor services during the next few hours and post updates should anything change.

  • Identified
    Identified

    We have identified the cause of the issue to be related to extremely high levels of inbound traffic on our vendor which is impacting our services We are pursuing multiple avenues with both internal and external vendors to mitigate the ongoing impact to our customers.

    We will continue to provide regular status updates on this page.

  • Investigating
    Investigating
    We are currently investigating this incident.